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Section 1. Introduction 
The HiperLogic Activation Filter (HAF) enables Windows HPC Server 2008 R2 compute jobs that use 
application licenses to wait until the required application licenses are available. An easy to use GUI enables 
simple configuration and integration. HAF is unique in its ability to support multiple different FlexLM 
applications in one application filter, as well as non-FlexLM applications through its plugin architecture. 

Most popular commercial HPC applications use FLEXlm™ technology for application licensing.  HAF 
includes out of the box support for unlimited FLEXlm licensed applications running with one instance of 
HAF. HAF 2.1 also includes support for the LSTC license server. 

Section 2. Before You Begin 
HAF requires the Microsoft HPC Pack 2008 R2 be installed on the cluster head node before installing the 
Activation Filter. The cluster should be validated it is properly configured and functioning before integrating 
HAF. 

Section 3. Installation 
To install the application, download the installation.zip, extract the contents and execute the setup.exe 
program on the head node of the cluster. Accept the EULA before continuing, or cancel the installation if you 
do not accept the license terms. 
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Figure 1. The license acceptance installation screen. 

Click through the installer to complete the installation. 

Step 1. Launch the Application Filter Configurator 
Click Start->HiperLogic ->Activation Filter Configurator to launch the HAF Configurator.  The HAF 
Configurator is responsible for testing and creating the master configuration file used by the HAF console tool.  

Next enter a license key, see Figure 4.  If this is an evaluation, click Continue Evaluation. If you have 
purchased the Activation Filter, click Install License and paste the license key from the email received from 
HiperLogic. 

 
Figure 2. Enter the license key. 

After entering your license key the application will launch, see Figure 5. 
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   Figure 3. The Activation Filter Configurator. 

Step 2. Add FLEXlm licensed applications 
The next step is to add the FLEXlm applications that will be checked by HAF. Only those applications 
configured here will be checked by HAF. To add your first application, click on the Add button shown in 
Figure 5. The application dialog shown in Figure 6 will appear.  

There are five required pieces of information for each application: feature name, program path, program 
arguments, provider type, and the program timeout. 

 

 

                     Figure 4. The Add Application Dialog. 
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Feature Name 
Enter the name of the licensed FLEXlm feature to check for. This name must also match the name in the 
HPCS job license definition. (See step five in this section).  

Program 
Enter the full path to the FLEXlm lmutil.exe executable. You can download the latest Microsoft Windows 64-
bit x64 lmutil.exe free of charge from Macrovision® at the follow URL:  

http://www.globes.com/support/fnp_utilities_download.htm 

NOTE: You must rename the binary to lmutil.exe for the binary to work properly. The examples in this 
document assume the binary is installed into c:\flexlm\lmutil.exe.  

Provider 
This drop down box is to choose the type of license server this application uses. FlexLM is the default and is 
the selection for the vast majority of applications. If you use LS-DYNA from LSTC, select LSTC. 

Arguments 
The last text box is for the arguments to the lmutil.exe command. The recommended argument for 
lmutil.exe is lmstat –a –c port@licenseserver where the port and licenseserver are to be filled in for your application. 
See Figure 7 for an example. Contact your license administrator or software vendor if you are unsure of the 
correct port and server for your application. 

Command Timeout 
The timeout increment indicates how long HAF should wait in seconds for a response from lmutil.exe before 
deciding that the job should not start. If you increase this value beyond fifteen seconds, there is an additional 
step to perform. (See section six for more details.) 

 

        Figure 5.  An example application configuration. 

Step 3. Testing the configuration 
After configuring the application settings, you will see the application will be listed in the list box. Highlight the 
application to test, and click the Test button to test the communication to your license server. If the settings are 

http://www.globes.com/support/fnp_utilities_download.htm


 

 5 

correct the output from lmutil.exe and the number of currently free licenses for the specified feature will be 
displayed, see Figure 8. 

 

 
   Figure 6. Example test output from license server communication test.. 

If there is an error, check the settings are correct. If they are correct see section five on debugging HAF. 

Step 4. Saving the Configuration 
The configuration now needs to be saved for use by HAF. Go to the File menu and choose Save. Click OK to 
accept the default filename ActivationFilter.config in the same directory where HAF was installed. See Figure 
9.  

NOTE: The filename must be ActivationFilter.config 
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Figure 7. Save the configuration file. 

Step 5. Create an example job for testing 
To create a test example job, launch the Windows HPC R2 Job Manager and fill in the job information, see 
Figure 10. Click the Licenses section on the left hand side, and then click the Add button. 

In the Feature text box type in the name of the FLEXlm feature this application requires.  

NOTE: The Feature should match the Feature name you entered in Step 2.  

Next in the Amount text field type in the amount of feature tokens/licenses required. 

Finally, save this job XML to c:\temp\testjob.xml by clicking on the Save Job as button in the lower right 
hand corner, see Figure 10. 
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Figure 8.  Creating a job template. 

Step 6. Simulate HAF action with the test job 
To simulate what action HAF would take with the test job created, click on the HAF Tools->Simulate menu 
item, see Figure 11. 

NOTE: If the configuration file ActivationFilter.config described in Step 4 was not saved, this menu 
item will not be enabled. 

 

Figure 9. The HAF simulation menu item 

Enter the path to the test job saved from Step 5, then click the Test button. See Figure 12. 
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Figure 10. Simulating HiperLogic Activation Filter allowing the test job. 

A dialog box will indicate if the job would have been allowed to run by HAF. The HAF log output is then 
displayed in the Output window area.  

Step 7. Enable HAF for production  
There are three different ways to enable HAF. The simplest way to enable HAF is to click the Tools-
>Activation Filter->Enable menu item. See Figure 13. 

NOTE: If the configuration file ActivationFilter.config described in Step 4 was not saved, this menu 
item will not be enabled. 

 
Figure 11. Enabling HAF. 

The filter can also be enabled manually using the Microsoft HPC Cluster Manager tool that comes with 
Windows HPCS under the Configuration tab-> Job Management section->Configure job scheduler 
policies and settings->Filter Tab. See Figure 14. 
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Figure 12. Enabling HAF through the Microsoft HPC Cluster Manager 

Alternatively, HAF may be enabled using the Windows HPCS cluscfg command. See section six on how to do 
this. 

After HAF is enabled, any queued and submitted jobs will now be subject to the HAF filter. 

Step 8. Monitoring HAF actions 
All actions performed by HAF are logged to the log file in %INSTALLDIR%\ActivationFilter.log where 
%INSTALLDIR% is the location HAF was installed, by default c:\Program Files 
(x86)\HiperLogic\ActivationFilter\. 

Open this log file with a text editor to see what allow/deny actions HAF is performing on jobs. 

Section 4. Disabling HAF for Production 
To disable HAF so Windows HPCS will schedule jobs without using the Activation Filter, click the Tools-
>Activation Filter->Disable menu item. See Figure 15. 
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Figure 13.  Disable HAF 

The filter can also be disabled manually using the Microsoft HPC Cluster Manager tool that comes with 
Windows HPCS under the Configuration tab-> Job Management section->Configure job scheduler 
policies and settings->Filter Tab. 

Alternatively, HAF can be disabled using the Windows HPCS cluscfg command. See section six. 

Section 5. Debugging HAF Activation Issues 
All actions performed by HAF are logged to the log file in %INSTALLDIR%\ActivationFilter.log where 
%INSTALLDIR% is the location HAF was installed to, by default c:\Program Files 
(x86)\ActivationFilter\. 

The log file will display the job ID and the reason the job was or wasn’t permitted. This section will list some 
things to check if HAF did not take the correct action for a job.  

Job is starting even though licenses are not available 
If a job starts when a license is not available, there are several reasons this could occur: 

1. The job license did not specify the correct feature name, or the feature name is misspelled. 

2. The job license did not specify all required FLEXlm features required by the application. 

3. The job license(s) did not specify enough token(s).  

4. The application feature name is not configured in HAF. HAF will ignore unknown license features in 
the job file and allow the job to run. 

5. The licenses were available when HAF checked, but by the time the application was launched on the 
compute nodes all licenses were in use. 

6. HAF was not enabled.  

Check the ActivationFilter.log file to see the root cause. 
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Job is not starting even though licenses are available 
If a job will not start because HAF is not allowing it, Pending Reason will be listed in the Job Manager. See 
Figure 16. If there is any other message in Pending Reason other than “Activation of this job was delayed 
by the activation filter program”, then HAF is not the reason the job is not starting.  

lmutil.exe is unable to talk to the FLEXlm server 
If there appears to be a communication error like the server is down, double check your server and port settings 
are correct. Also make sure there is no firewall between the cluster head node and your FLEXlm server. 

If lmutil.exe is communicating, but you are getting erroneous output, make sure the lmutil.exe being used is 
the same or greater than the version used by the application server. Download the latest version as 
recommended in Section One/Step Two to avoid this issue.  

Section 6. Advanced Topics 
Increasing the Windows HPC Server activation filter timeout  
Windows HPCS by default has a fifteen second timeout for the activation filter program. If HAF takes longer 
than fifteen seconds for a query, Windows HPC Server will kill HAF and not allow the job to start. 

If HAF is configured to have an application query wait for longer than fifteen seconds, the Windows HPC 
Server activation filter timeout will have to be greater than your HAF settings. 

For example, to increase the Windows HPC Server activation filter program timeout to thirty seconds type the 
following command on the head node at the Windows command prompt: 

cluscfg setparams ActivationFilterTimeout=30 

To view that the current setting type the following at the command prompt: 

cluscfg listparams 

Disabling/Enabling HAF using cluscfg 
The cluscfg command included with Windows HPC Server allows the activation filters to be enabled or 
disabled. To use this command to disable HAF type the following command at the Windows HPC Server 
command prompt: 

cluscfg setparams ActivationFilterProgram=”” 

Alternatively use the Tools->Activation Filter->Disable menu command in HAF. 

To enable HAF, use the  

cluscfg setparams ActivationFilterProgram=”prog”  

Where prog is the full path to the ActivationFilter.BAT file. Alternatively use the Tools->Activation Filter-
>Enable menu command in HAF. 
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Using HAF with the job command 
License features can be added with the Windows HPC Server job command line by using the /license option. 
For example, to submit a job that requires four licenses of MYFEATURE, the command line would be  

job submit /numprocessors:4 /license:myfeature:4 myapp.exe  

Command line usage  
The HAF Configurator graphical user interface is a front end that interacts with the console HAF 
ActivationFilter.exe application.  

To change the default logging level, change the location of the default configuration file, or the default location 
of the log file, then interact directly with the ActivationFilter.exe command instead of using the HAF 
Configurator. 

To use HAF directly, start a Windows command prompt and change to the HAF installation directory. 

Next, type the ActivationFilter.exe /? to see the example usage. See Figure 17. 

 
Figure 14. Using ActivationFilter.exe 

There are several options to ActivationFilter.exe to override the default settings. For example, to increase the 
logging from Info to Verbose type: 

ActivationFilter.exe /Debug:Verbose   <Job File> 

Where <Job File> is the HPCS XML job created in Step 6.  
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Section 7. Holding Jobs in the Queue Until the Future  
HAF can make a job wait in the queue until a date in the future before it will be considered to run. This is 
useful if you have a large job that uses many licenses you would like to run after-hours or until the weekend, or 
if you have resources being used on workstations during the certain hours and don’t want submitted jobs to 
interfere. 

To enable this functionality define a environment variable on the job named WAITUNTIL that contains the 
date and time to that the job should start being available to run. For example, if you want the job to wait until 
October 19th, 2011 at 11:00 PM before being considered to run, the value of WAITUNTIL should be set to: 

         10/19/2011 11:00:00 PM 

The previous example assumes your computer culture is set to English (United States) in the Regional and 
Language item in Windows Control Panel. If your language or culture is set to a different value, you must use 
a date string appropriate for you locale. 

Setting the environment variable on the job can be done many ways including the HPC job manager, through 
the command line, or through your native interface. For example, to submit the previous example via the 
command line: 

job submit /env:WAITUNTIL=”10/19/2011 11:00:00 PM” myapp.exe  

Section 8. Contacting Support  
Please read our Frequently Asked Questions in this section before contacting support: 

Q: I installed HAF, but my jobs still go through when there are no licenses, what is wrong? 

A: There are several things to check for: 

1. Is HAF enabled? 

2. Does the job license feature match what is configured in HAF? 

3. Was the license information added to the job? 

4. Did the ActivationFilter.log file indicate anything? 

Q: Can I release a single job from the Activation Filter? 

A: The current release does not allow control of individual job activation. If a job is held by the Activation filter 
in the Q state that needs to continue (for example the user made a typo in the number of licenses required) then 
right click on the job in the Job Manager and choose modify to change the licenses.  

Q: We had a job HAF allowed through with sufficient licenses, but we received a job error that the application 
couldn’t obtain license, what causes this? 
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A: There are several possibilities: 

1. The user did not specify the correct number of licenses required in the job. 

2. The user did not have the complete list of required features in the job. 

3. The user spelled the feature wrong, or used the wrong case in the job. 

4.  It is possible HAF allowed the job to run by checking for sufficient licenses, but in the window of time it 
took to start the licensed application another user grabbed the needed licenses.. 

Q:  We use a commercial application that submits directly to the cluster, the application does not use the job 
command or the HPC Job Manager to submit jobs.  We contacted the vendor, and they do not have a 
workaround to add license information to the job through the application. Can this application work with 
HAF? 

A: Yes, HiperLogic can provide a custom solution on a consulting basis. Please contacts sales@hiperlogic.com 
for a quote if you encounter this issue during your trial. 

If you do not find an answer to your question, please email support@hiperlogic.com with your question. Please 
include your ActivationFilter.config and ActivationFilter.log file from C:\Program Files 
(x86)\HiperLogic\ActivationFilter in your email. 

Section 8. Extending HAF  
HAF has an extensible plug-in framework to allow for other license technologies for your site. Please contact 
sales@hiperlogic.com  to discuss a consulting engagement if you require special customization.  

Section 9.  What’s New in HAF  
Release 2.2 This release supports a Hold Until provider that enables a job to be held in the queue until a future 
date specified by the user. 

Release 2.1 This release adds supports for the LS-DYNA license manager through a new HAF provider.  

Release 2.0 This release supports HPC Server 2008 R2. The new HPC Server 2008 R2 capability to allow a job 
to re-queue if licenses are not available is now the default behavior in HAF 2.1. 
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